ความรู้คู่ความก้าวหน้า
 
 

Layer 3 Switch โลกมืดที่หลายคนนึกไม่ออก (แปลง command เป็นภาพ)

1. โดยปกติแล้ว เรามักจะเห็น Network Diagram ที่เป็นแบบ Physical View พร้อมกับ configuration ดังรูปที่ 1 และแน่นอนว่า เวลาระบบมีปัญหาแล้ว เราต้องมา troubleshooting กับ Diagram แบบนี้นั้น มันเป็นเรื่องที่ยาก และเข้าใจได้ยาก

ไม่มีคำอธิบายรูปภาพ

2. เพราะหลายๆ คน โดยเฉพาะเด็กใหม่ในวงการ แม้จะสามารถแก้ปัญหาได้ แต่อาจจะงงๆ บ้าง หรือบางคนไล่ปัญหากันไม่ถูกเลยทีเดียว ดังนั้นผมจึงทำการแปลงเป็นภาพเนื้อในของ L3 Switch เทียบกับ command line ซึ่งผมจะเรียกมันว่า Logical View 

ไม่มีคำอธิบายรูปภาพ

ไม่มีคำอธิบายรูปภาพ


โดยสรุปจากรูปที่ 2 และ 3 จะได้ดังนี้ครับ
2.1 จากรูปที่ 2: Gi0/1 และ Gi0/4 เป็น SwitchPort 
- Gi0/1 และ Gi0/2 เป็นสมาชิก VLAN 10
- Gi0/3 และ Gi0/4 เป็นสมาชิก VLAN 192
2.2 จากรูปที่ 3: Gi0/5 เป็น RoutePort (Comand "no switchport")

3. สรุป Concept จากภาพได้ดังนี้ครับ:
3.1. VLAN เทียบเท่า Virtual Switch 
3.2. SwitchPort จะเป็น Layer 2 Port และไม่สามารถ configure IP address บน Interface นี้ได้ ซึ่งจากภาพตัวอย่างถูก configure ให้ Access Port ซึ่งก็เปรียบเสมือนขาของ Virtual Switch ของ VLAN นั้นๆ ที่มันเป็นสมาชิก
3.3. Layer 3 Switch ที่ถูก Enable Function Layer 3 ด้วยคำสั่ง "ip routing" แล้ว จะเสมือนว่า L3 Switch ตัวนี้มี Virtual Router อยู่ตัวนึง ฝังอยู่ข้างใน ซึ่งในความเป็นจริงแล้ว มันก็คือ Routing Table นั่นเอง
3.4. Interface VLAN ก็เทียบเท่าขาของ Virtual Router และเชื่อมต่อไปยัง Virtual Switch (VLAN) นั้นๆ ที่มันอ้างถึง โดย Interface VLAN สามารถ configure IP address ได้ และทำหน้าที่เป็น Gateway ของ Host ใน VLAN นั้นๆ
3.5. RoutePort (Physical interface ที่ถูกใส่ command "no siwtchport") จะเป็น Layer 3 port ซึ่ง Physical interface ที่เป็น RoutePort นั้นๆ จะถูกมองเป็นเสมือน Interface ของ Virtual Router เลย และสามารถใส่ IP address ได้ ซึ่งโดยส่วนใหญ่จะถูกนำมา configure เป็น WAN link หรือ Point-to-Point link

ผมเชื่อว่ารูปที่ 1 ถึง 3 จะทำให้พี่ๆ น้องๆ เข้าใจเนื้อใน กับ command line ของ Layer 3 switch ได้มากขึ้นนะครับ
---------------------------------
4. หากใครอยากศึกษาเพิ่ม ลองเข้าไปดูตาม link นี้นครับ

4.1. อยากให้ท่านลองไปดู VDO ตาม link ก่อนนะครับ
https://www.bloggang.com/viewblog.php…

4.2. และลองไปดูเรื่องพื้นฐานของ VLAN ตาม link นี้ก่อนครับ

4.2.1 VLAN ตอนที่ 1
https://www.bloggang.com/viewblog.php…


4.2.2 VLAN ตอนที่ 2
https://www.bloggang.com/viewblog.php…

4.3. การทำให้ PC สองเครื่อง ที่อยู่คนละ VLAN สามารถติดต่อกันได้บน Layer 3 Switch
https://www.bloggang.com/mainblog.php…

หวังว่า post นี้จะเป็นประโยชน์กับพี่ๆ น้องๆ นะครับ

(จริงๆ แล้ว บทความนี้ ถูก post ตั้งแต่เมื่อวันที่ 7 เมษายน 2562 ใน Face ส่วนตัว แต่เพราะผมเห็นว่า น่าจะมีประโยชน์กับส่วนรวม เลยมา post ใน page นี้ หากต้องการติดตามข้อมูลที่เป็นประโยชน์ ทุกๆ post สามารถติดตามได้จาก face ผมโดยตรงได้นะครับ เพราะอาจจะมีบาง post ที่มีเฉพาะ ใน face ส่วนตัวครับ)

โก้-ชัยวัฒน์ (KoChaiwat)




 

Create Date : 16 สิงหาคม 2562   
Last Update : 16 สิงหาคม 2562 23:55:26 น.   
Counter : 1772 Pageviews.  
(โหวต blog นี้) 


Double redistribution on a single router (same router)



การ redistribute route ที่หลายๆ คนยังไม่รู้อีกเรื่องหนึ่ง นั่นก็คือ การทำ Double Redistribution ภายใน Router ตัวเดียวกัน (Double Redistribution on a single router or the same router)

จากสิ่งที่ถูกค้าสอบถามมาแม้ผมจะตอบคำถามไปแล้ว แต่ก็พยายามหาข้อมูลอ้างอิงใน Web ซึ่งหาเท่าไหร่ก็ไม่เจอ แต่จำได้ว่ามี สุดท้ายนึกได้ว่า สอนในวิชา CCNP ROUTE เลยไปค้นเอกสารดู และเจอจนได้ (ไม่งั้นฝันว่านอนไม่หลับทั้งคืนแน่นอน) เลยวาดรูป และแชร์เป็นความรู้ซะเลยเพราะเชื่อว่าเป็นประโยชน์กับพี่ๆ น้องๆ


1. จากรูป R3 run routing protocol ทั้งหมด 3 protocol ประกอบไปด้วย RIP, EIGRP และ OSPF โดยมีการ redistribute route จาก RIP --> EIGRP--> OSPF

2. จากรูป Net X ถูกประกาศจาก R1 ผ่าน routing protocol RIP และ Net Y ถูกประกาศจาก R2 ผ่าน routing protocol EIGRP

3. R3 ทำการ redistribute Net X จาก RIP ไปยัง EIGRP

4. R3 ทำการ redistribute route ทั้งหมดซึ่งประกอบไปด้วย Net X และ Net Y จาก EIGRP ไปยัง OSPF แต่ทว่า ด้วยกฎของการ redistribute route บน Cisco router แล้ว จะไม่อนุญาติให้ทำการ double redistribute route (redistribute route สองครั้ง) บน router ตัวเดียวกันได้

ดังนั้น Net X จึงไม่สามารถที่จะถูก redistribute จาก EIGRP ไปยัง OSPF ได้

5. R3 ประกาศเพียงแค่ Net Y เท่านั้น ไปยัง R4

เหตุที่ Cisco router ไม่ยอมให้ทำการ double redistribute route เนื่องจากเป็นกลไกการป้องกันการเกิด routing loop นั่นเอง

*** ดังนั้นวิธีแก้ปัญหา หากต้องการให้ router R4 ได้รับ Net X แล้ว ให้ทำการ redistribute โดยตรงระหว่าง routing protocol RIP กับ OSPF เลยนะครับแต่ก็ต้องระวังเรื่อง routing loop ให้ดี โดยสามารถศึกษาเรื่อง routing loop ได้จาก link ข้างล่างครับ

https://web.facebook.com/chaiwat.amorn/posts/2297431380298757


สำหรับตัวอย่าง configuration เพื่อให้พี่ๆ น้องๆ ไปลงอทำ lab กัน ดังนี้ครับ



Configuration:

R1:

!
hostname R1
!
interface Loopback0
 description Net X
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 10.1.3.1 255.255.255.0
!
router rip
 version 2
 network 1.0.0.0
 network 10.0.0.0
 no auto-summary
!
end

=======================

R2:

!
hostname R2
!
interface Loopback0
 description Net Y
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 10.2.3.2 255.255.255.0
!
router eigrp 1
 network 2.0.0.0
 network 10.0.0.0
!
end


=======================

R3:

!
hostname R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback13
 ip address 13.13.13.13 255.255.255.255
!
interface Loopback23
 ip address 23.23.23.23 255.255.255.255
!
interface Loopback34
 ip address 34.34.34.34 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 10.1.3.3 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 10.2.3.3 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 10.3.4.3 255.255.255.0
!
router rip
 version 2
 passive-interface GigabitEthernet0/1
 passive-interface GigabitEthernet0/2
 network 10.0.0.0
 network 13.0.0.0
 no auto-summary
!
router eigrp 1
 network 10.2.3.0 0.0.0.255
 network 23.23.23.23 0.0.0.0
 redistribute rip metric 10000 100 255 1 1500
!
router ospf 2
 redistribute eigrp 1 subnets
 network 10.3.4.0 0.0.0.255 area 0
 network 34.34.34.34 0.0.0.0 area 0
!
end

=======================

R4:

!
hostname R4
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/2
 ip address 10.3.4.4 255.255.255.0
!
router ospf 2
 network 0.0.0.0 255.255.255.255 area 0
!
end

============================










เมื่อเปรียบให้:

- Net X = 1.1.1.1/32
- Net Y = 2.2.2.2/32

จากรูปการ show ip route บน R3 จะเห็นว่า:

- R3 ได้รับ Net 1.1.1.1/32 มาจาก R1 ผ่านทาง routing protocol RIP 
- R3 ได้รับ Net 2.2.2.2/32 มาจาก R2 ผ่านทาง routing protocol EIGRP

แต่เมื่อไป show ip route บน R4 จะพบว่า R4 เห็นเพียงแค่ Net 2.2.2.2/32 เท่านั้น และไม่เห็น Net 1.1.1.1/32 ซึ่งเป็นไปตามกฎที่ได้กล่าวเอาไว้

หวังว่าจะเป็นประโยชน์กับพี่ๆ น้องๆนะครับ

ปล. ขนาดป่วยก็ยังไม่วายแชร์ความรู้ ก็ใจมันรักอ่ะ 555


โก้-ชัยวัฒน์ (
KoChaiwat)




 

Create Date : 09 พฤศจิกายน 2561   
Last Update : 9 พฤศจิกายน 2561 18:25:03 น.   
Counter : 935 Pageviews.  


ความน่าจะเป็นที่ทำให้ใช้งาน Internet ได้ช้า



Internet ช้ามีได้หลายสาเหตุ

1. ปัญหาจาก Network
a) Organization Network (internal network)
b) Link ระหว่าง Organization Network กับ ISP
c) ISP network
2. ปัญหาจาก DNS Server slow response
3. ปัญหาจาก Web Server slow response

Investigation หรือการตรวจสอบหาสาเหตุ

1. ช้าสำหรับทุกคนไหม?
a) ถ้า Internet ไม่ได้ช้า สำหรับทุกคนในองค์กรแล้ว ก็อาจจะมาจากความรู้สึกของ User ซึ่งต้องวัดด้วย tools อย่าง Wireshark ดู RTT ที่เก็บไว้เป็น baseline ตอนปกติเทียบกับตอนที่มีปัญหา หรือ user คนนั้นกำลังติดสปายแวร์และไวรัส โดยมันอาจจะกำลังรบกวนเบราว์เซอร์ของ user รายนั้นๆ อยู่
b) ถ้าช้าเป็น Zone ก็อาจจะมีปัญหา congestion (traffic แออัด/คอขวด) หรือเกิด Errors บน common link หรือ link ที่ใช้งานร่วมกัน สำหรับ Zone นั้นๆ
c) ถ้าช้าสำหรับทุกคน
• Link to Internet Gateway problem
- Link to ISP เกิด congestion (traffic แออัด)
- Link to ISP มี Errors 
• ISP problem
• Device Performance (เช่น CPU/Memory overload):
- Gateway router เคยใช้งานได้ดี แต่เมื่อ Internet traffic โตขึ้นมากๆ แล้ว performance ของ Gateway router ที่ใช้งานอยู่ในปัจจุบันอาจจะไม่เพียงพอต่อการใช้งาน เมื่อเทียบกับปริมาณการใช้งานของ Internet traffic ในปัจจุบัน
- มีการติดตั้ง Firewall หรือ IPS ในรูปแบบ inline หรือไม่? (เอา Firewall หรือ IPS มาขั้นกลาง Internet traffic) ซึ่งในช่วงติดตั้งแรกๆ ตอนปริมาณ Interface traffic ยังไม่เยอะ ก็สามารถใช้งานได้ดี แต่เนื่องด้วยปริมาณ traffic ที่โตขึ้น ก็อาจจะทำให้ Firewall ที่ใช้งานอยู่ปัจจุบัน มี performance ที่ไม่เพียงพอแล้ว สำหรับปริมาณ traffic ในปัจจุบัน หรือที่เรียกว่า เกิดปัญหา "คอขวด" 
- การใช้งาน Internet traffic จะต้องผ่าน Proxy Server ไหม? --> ซึ่งการใช้งาน Internet ในปัจจุบัน มีการใช้งาน traffic เป็นประมาณมหาศาล ดังนั้น solution proxy server อาจจะกลายเป็นปัญหาคอขวดได้ ในกรณีที่ performance ของ proxy server ไม่ไหวแล้ว
- Router หรือ Firewall ที่ถูกนำมาใช้ในการ NAT private IP address to public IP address อาจจะมีจำนวน NAT concurrent session ที่มากเกินขีดความสามารถของอุปกรณ์ที่จะรองรับได้ ซึ่งก่อนหน้านี้ การใช้งาน Internet traffic อาจจะมีไม่มาก ทำให้อุปกรณ์ยังสามารถรองรับปริมาณ NAT session ได้ดี แต่เมื่อปริมาณ traffic มากขึ้นเรื่อยๆ จะไปถึงจุด maximum NAT session แล้ว อุปกรณ์อาจจะมีการ drop traffic บ้าง ทำให้การใช้งาน Internet ช้าลงได้

2. ช้าในช่วงเวลาเดียวกันของทุกวันไหม?
a) อาจจะมี bulk traffic (traffic ขนาดใหญ๋) อย่างเช่น backup traffic หรือ traffic ประเภท database กำลังถูกรับส่งอยู่ใน network แบบเป็นช่วงเวลาที่แน่นอนของทุกๆ วันไหม
ซึ่งหากมี traffic ประเภทนี้รับส่งอยู่ในช่วงชั่วโมงเร่งด่วน หรือชั่วโมงของการทำงานแล้ว traffic ประเภทนี้อาจจะเข้าไปแย่ง bandwidth ของ link และทำให้เหลือ bandwidth ที่จะใช้งานในขณะนั้นน้อยมาก จนเกิด congestion หรือเกิดความแออัดของ traffic ใน network จนต้องมีการ drop ของ traffic เกิดขึ้น 
Note: ปัญหานี้ สามารถแก้ไขได้ โดยการตั้ง schedule ของ bulk traffic ให้มีการรับส่งในช่วงเวลาดึกๆ หรือช่วงที่ไม่ใช่ชั่วโมงเร่งด่วน
b) ในกรณีที่มีการใช้งาน QoS แล้ว ให้พิจารณาว่า การจัดสรร bandwidth ให้กับ traffic ชนิดต่างๆ ในขณะนี้ เหมาะสมกับปริมาณการใช้งานจริง ในปัจจุบันหรือไม่? 
c) พนักงานในบริษัท มีการดู Youtube หรือ Multi media อื่นๆ ในระหว่างวันหรือไม่ และดูเยอะไหม (ปริมาณ traffic ประเภท multimedia มีเยอะไหม)?
d) Link utilization หรือ Device Performance overloading เพราะมีการใช้งานแบบปกติพร้อมๆกันในเวลาเดียวกัน ซึ่งเกี่ยวข้องกับพฤติกรรมของ user เช่น ใช้งาน network พร้อมๆ กัน ด้วย application ที่รับส่ง data traffic ปริมาณมากๆ ในช่วงระหว่างวันทำให้ใช้งานช้า แต่ช่วงเช้าๆ ก่อนเริ่มงาน หรือหลังเลิกงาน สามารถใช้งานได้ดี
e) อาจจะเป็นปัญหา congestion ใน network ของ ISP

3. ใน office มีใครติดไวรัส แล้วยิง traffic ออกมารบกวนไหม?
หรือ เครื่อง client เครื่องที่ช้า ติด virus/bot/spyware และเครื่อง client เครื่องนั้น กำลัง update ข้อมูลในเครื่องออกไปให้ hacker ใน Internet ทำให้เครื่อง client เครื่องนั้นๆ ทำงานช้า

4. มี Traffic ประเภท bittorrent กำลังถูกใช้งานอยู่ภายในองค์กรหรือไม่?
ปัญหาหนึ่งของการใช้งาน Internet ช้า เพราะมีการใช้ application ประเภท bittorrent อยู่ภายในองค์กร ซึ่ง application ประเภทนี้ จะพยายามใช้ bandwidth ที่มีอยู่ให้มากที่สุด จนทำให้ไม่เหลือ bandwidth ให้ใช้งานสำหรับ application ประเภทอื่น นั่นคือเราไม่สามารถใช้งาน Internet ทั่วๆ ไปได้เลย หรือถ้าใช้งานได้ ก็จะใช้งานได้ช้ามากๆ จนรู้สึกปวดตับกันเลย

5. การ design subnet นั้น มี broadcast domain ที่ใหญ่เกินไปไหม? และ Client หรือ host มีการส่ง traffic แบบ broadcast ในปริมาณที่มากไหม 
Note: การจะบอกว่า traffic แบบ broadcast มีมากเกินไปไหม ไม่สามารถบอกเป็นตัวเลขที่แน่นอนได้สำหรับการใช้งานในแต่ละที่ แต่ให้ทำการเก็บ baseline หรือเก็บข้อมูลประมาณ broadcast traffic ในยามที่ใช้งานได้เป็นปกติ เพื่อไว้เทียบกับประมาณของ broadcast traffic ตอนมีปัญหา เพื่อดูว่ามันต่างกันมากไหม? แล้วนำมาพิจาณาต่อว่า "ควรจะมีการแบ่ง subnet หรือย่อย broadcast domain ให้เล็กลงไหม?"

6. ใช้งานช้า เฉพาะกับการใช้งานผ่าน WiFi หรือเปล่า?
a) อาจจะเกิดจากการติดตั้ง AP (Access Point) ที่ไม่ครอบคลุม หรือไม่ทั่วถึง หรือติดตั้งไว้ตรงจุดอับสัญญาณ หรือมีแผ่นโลหะมาขวางคลื่นสัญญาณที่ถูกปล่อยออกมาจาก AP (สัญญาณ WiFi ไม่สามารถผ่านโลหะได้)
b) มีการออกแบบ channel ของความถี่ที่ไม่ดี หรือใช้ channel ที่ซ้ำซ้อนกันบน AP ที่วางใกล้ๆ กัน 
เช่น AP สองตัวที่วางใกล้ๆ กัน ถูก set ให้ใช้ channel เดียวกัน ทำให้คลื่นสัญญาณ WiFi ของ AP ทั้งสองตัว รบกวนกันเอง ส่งผลให้ performance ของการใช้งานผ่าน WiFi ไม่ดี และทำให้ใช้งาน Internet ได้ช้า

สำหรับปัญหาเรื่อง channel ของ WiFi overlapping หรือซ้ำซ้อน หรือรบกวนกัน นั้น หากท่านกำลังใช้ WiFi ที่ย่านความถี่ 2.4 GHz แล้ว ท่านจะมี channel ที่จะ set เพื่อไม่ให้ชนกันเพียงแค่ 3 channel เท่านั้น คือ Channel 1, 6 และ 11 ซึ่งในกรณีที่มีการใช้งานตามบ้านแล้ว รับรองเลยว่าหลบไม่ให้ชนยากมากๆ ซึ่งหากท่านต้องการที่จะแก้ปัญหา คลื่นรบกวนจากปัญหา channel ชนกันแล้ว ขอแนะนำให้ใช้ WiFi ที่ย่านความถี่ 5 GHz ครับ (สมัยก่อน 5 GHz ไม่อนุญาติให้ใช้ แต่ปัจจุบัน ถือว่าถูกกฎหมายแล้ว) โดยย่านความถี่ 5 GHz จะมี channel ให้ท่านเลือกได้ถึง 24 channel ที่จะไม่ทำให้เกิดคลื่นรบกวนกัน 





ภาพข้างล่าง เป็นตัวอย่างของคลื่นความถี่ที่ไม่ทับซ้อนกัน ของ WiFi ย่านความถี่ 2.4 GHz โดยให้ focus ที่ Channel 1, 6 และ 11



Note: ภาพประกอบถูกนำมาจาก link ข้างล่างครับ

c) อาจจะติดตั้ง AP ไว้ตรงจุดที่มีอุปกรณ์เครื่องใช้ไฟฟ้าที่ผลิตคลื่นความถี่เดียวกันกับสัญญาณ WiFi (เช่น โทรศัพท์บ้าน, ตู้เย็น และเตาไมโครเวฟเป็นต้น) ทำให้เกิดการรบกวนกันของสัญญาณ
Note: หากต้องการแน่ใจว่า ปัญหาการใช้งาน Internet ช้า มาจากปัญหาของ WiFi แล้ว ให้ทดลองนำเครื่อง Computer มาต่อตรงๆ กับสาย LAN แล้วทดสอบการใช้งาน Internet  ผ่านสาย LAN เทียบกับ WiFi ดู

d) สำหรับ Internet ตามบ้าน: สำหรับ Internet ตามบ้านแล้ว หากการใช้งาน Internet ผ่าน Wireless router ช้านั้น แนะนำให้ลอง reset หรือปิดเปิดอุปกรณ์ Wireless router สักรอบครับ และหากเป็นไปได้ ควรปิดเปิด Wireless router ทุกๆ วันอย่างน้อยวันละครั้ง เพื่อเป็นการ reset ให้มันพักแพร๊พนึง และกลับมาเริ่มต้นทำงานใหม่ และในกรณีที่ Wireless router ถูกติดตั้งอยู่ชั้น 1 แต่เรานั่งใช้งาน Internet อยู่บนชั้น 3 ผ่าน WiFi แล้ว เราจะพบกับปัญหาเรื่องสัญญาณ WiFi อ่อน และการใช้งาน Internet จะใช้งานได้ช้า หรือใช้ได้บ้าง ไม่ได้บ้าง ซึ่งปัญหานี้ ขอแนะนำให้ซื้อ Wireless Router Repeater มาใช้งาน เพื่อทำการ repeat หรือทวนสัญญาณ โดยให้ติดตั้งที่ชั้น 2 (กรณีอาคาร 3 ชั้น) และให้ set เป็น mode repeater ซึ่ง AP ตัวนี้จะรับสัญญาณ WiFi จากชั้น 1 (เกาะ หรือ connect กับ SSID ของชั้น 1) และปล่อยสัญญาณ WiFi ใหม่จากตัวมันออกมาเป็นอีก SSID หนึ่ง จากนั้น ก็ให้ computer ของเราที่ใช้งานอยู่บนชั้น 3 ไปเกาะ หรือ connect SSID ใหม่ของ Wireless Router Repeater ที่ถูกติดตั้งอยู่ชั้นที่ 2
แค่นี้ ชีวิตการใช้งาน Internet ที่ชั้น 3 ก็จะดีขึ้นอย่างไม่น่าเชื่อ 

คำถาม: จะต้องมีการลากสาย LAN ระหว่าง WiFi router ที่อยู่ชั้น 1 มายัง 
Wireless Router Repeater ที่อยู่ชั้น 2 ไหม?

คำตอบ
ไม่ต้องมีการลากสาย LAN จาก router ตัวแรกที่อยู่ชั้น 1 มายัง 
Wireless Router Repeater ที่ชั้น 2 เลยครับ สะดวก และประหยัดมากๆ ราคาก็ไม่แพงครับ ราคาราวๆ 700 - 1,000 บาท ก็ใช้งานได้แล้วครับ

ตัวอย่างภาพ 
Wireless Router Repeater



ตัวอย่างภาพ การ setup เป็น Repeater Mode ของ Wireless Router Repeater





ที่มาของภาพ Wireless Router Repeater: จาก LAZADA

Note: รุ่นและยี่ห้อในรูป เป็นตัวที่ผมกำลังใช้งานอยู่จริง และก็ใช้งานได้ดีครับ แต่เพราะเกรงว่า พี่ๆ น้องๆ ที่กำลังอ่านบทความนี้ จะมองว่า ผมกำลังโฆษณาขายของให้เค้า เลยต้องปิดบังยี่ห้อไว้นิดนึงนะครับ 


ตัวอย่งาการใช้งานจริง ที่ผมใช้งานอยู่ สำหรับ Internet/WiFi ในบ้าน






ปล. เนื้อหาทั้งหมดเป็นแค่แนวทาง หรือแนวคิด เพื่อนำไปหาปัญหา ซึ่งอาจจะมีสาเหตุอื่นๆ อีกที่เป็นไปได้ อย่างไรก็แล้วแต่ หากผมมีข้อมูลเพิ่ม ก็จะมา update บทความนี้ต่อไปครับ


ขอบคุณครับ

โก้-ชัยวัฒน์





 

Create Date : 23 กันยายน 2561   
Last Update : 20 ตุลาคม 2561 23:25:56 น.   
Counter : 3735 Pageviews.  


การทำให้ PC สองเครื่อง ที่อยู่คนละ VLAN สามารถติดต่อกันได้บน Layer 3 Switch


  ก่อนจะลองทำตามตัวอย่างในภาพ อยากให้ท่านลองไปดู VDO ตาม link ก่อนนะครับ

 
 
และลองไปดูเรื่องพื้นฐานของ VLAN ตาม link นี้ก่อนครับ
 
VLAN ตอนที่ 1
 
 
VLAN ตอนที่ 2
 
เอาล่ะ! เรามาดูตัวอย่าง configuration ตามภาพกันเลย
 
 
แบบที่ 1: ตามภาพ จะเป็น Default
 
Configuration จากโรงงานเลย คือ
 
1. Layer 2 และ Layer 3 Switch ของ Cisco และ Managed Switch ทุกๆ ยี่ห้อ จะมี VLAN 1 ให้มาโดยกำเนิด โดยไม่สามารถลบ หรือแก้ไขอะไรได้เลย
 
2. Physical interface ทุกๆ interface ของ Switch จะเป็นสมาชิกของ VLAN 1 โดยกำเนิด จนกว่าจะมีการย้ายความเป็นสมาชิกของ VLAN แบบ manual
 
 
 
แบบที่ 2: มีการสร้าง VLAN ใหม่ขึ้นมา และมีการย้าย Physical interface บาง interface จากการเป็นสมาชิกของ VLAN 1 ไปเป็นสมาชิกของ VLAN ใหม่ที่ถูกสร้างขึ้นมา 

จากนั้นก็ทำการสร้าง interface VLAN สำหรับ VLAN ใหม่ที่เพิ่งถูกสร้างขึ้นมา พร้อมกับการ configure IP address เพื่อเอามาเป็น Gateway ของ VLAN (Subnet) นั้นๆ และเพื่อเอามาทำ routing ระหว่าง VLAN หรือเพื่อให้ VLAN สองวงคุยกันได้
 
แต่ช้าก่อน!!! เพียงเท่านี้ยังไม่เพียงพอ ท่านจะต้องทำการ enable ความสามารถของ Layer 3 หรือความสามารถในการทำ routing ให้กับ Layer 3 Switch ของ Cisco ด้วย โดยการใช้ command "ip routing" เพราะโดย default แล้ว ความสามารถในการทำ routing ของ Layer 3 Switch ของ Cisco จะถูก disable เอาไว้ และโดย default แล้ว Layer 3 Switch จะทำตัวเสมือนเป็นแค่ Layer 2 Switch
 
ดังนั้นหากใครต้องการใช้ความสามารถ Layer 3 แล้ว ท่านจะต้องทำการ enable Layer 3 routing ด้วยตัวท่านเอง แบบ manual ซึ่งตรงนี้เป็นสิ่งที่มือใหม่หลายๆ ท่านจะไม่ทราบ

จากภาพตัวอย่าง:
 
1. สร้าง VLAN:
- สร้าง VLAN 10 สำหรับ Subnet 10.1.1.0/24
- สร้าง VLAN 192 สำหรับ Subnet 192.168.1.0/24
 
2. Configure Access Port สำหรับสำหรับ VLAN แต่ละวงให้เหมาะสม จากภาพแล้ว
- Interface Gi0/0 ถูก configure ให้เป็น Access Port และเป็นสมาชิกของ VLAN 10 สำหรับ Subnet 10.1.1.0/24 (โดย default เป็นสมาขิกอยู่ VLAN 1)
- Interface Gi0/1 ถูก configure ให้เป็น Access Port และเป็นสมาชิกของ VLAN 192 สำหรับ Subnet 192.168.1.0/24 (โดย default เป็นสมาขิกอยู่ VLAN 1)
 
3. สร้าง Interface VLAN และ Configure IP Address ที่จะใช้เป็น Gateway สำหรับ VLAN หรือ Subnet วงนั้นๆ
- สร้าง Interface VLAN 10 และ configure IP address 10.1.1.254 เพื่อเป็น Gateway ให้กับ PC ทั้งหมดที่อยู่ใน VLAN 10 หรือ Subnet 10.1.1.0/24
- สร้าง Interface VLAN 192 และ configure IP address 192.168.1.254 เพื่อเป็น Gateway ให้กับ PC ทั้งหมดที่อยู่ใน VLAN 192 หรือ Subnet 192.168.1.0/24
 
4. สิ่งที่หลายๆ คนมักจะลืม รวมถึงผมด้วย คือ เวลาเราสร้าง Interface VLAN ใดๆ ขึ้นมาใหม่ มันจะถูก shutdown ไว้โดย default 
ดังนั้นเราจะต้องไป "no shutdown" ภายใต้ Interface VLAN ด้วยตัวเราเองทุกครั้ง
 
5. Enable Layer 3 routing ด้วยการใส่ command "ip routing" ที่ Global Configuration Mode [Router(config)#]
 
 
 
แบบที่ 3: จะทำให้ Switch ทำตัวเป็นเสมือน Router โดยเป็น Router เสมือน ที่มี Port Ethernet จำนวนหลายๆ Port โดยการไป configure IP address (ที่จะถูกใช้เป็น Gateway ให้กับ PC ใน VLAN วงนั้นๆ) บน Physical Interface โดยตรงได้เลย

Note: ไม่ต้องไปสร้าง Interface VLAN เหมือนอย่างแบบที่ 2

 
แต่มีสิ่งหนึ่งที่ท่านจะต้องทราบ และจะต้องทำก่อนที่จะไป configure IP address บน Physical Interface นั่นก็คือ: โดย default แล้ว Physical Interface ทุก Interface ของ Layer 3 Switch (ไม่นับ Interface VLAN) จะเป็น Layer 2 Interface (หรือที่เรียกว่า SwitchPort)

ดังนั้น หากท่านต้องการไป configure IP Address บน Physical Interface แล้ว ท่านจะต้องทำ Physical Interface ให้กลายเป็น Layer 3 Interface (หรือที่เรียกว่า RoutePort) เสียก่อน
โดยการใส่ command
"no switchport" ภายใต้ Physical Interface นั้นๆ

Note: หากท่านไม่ใส่ command 
"no switchport" ภายใต้ Physical Interface แล้ว ท่านจะไม่สามารถ configure IP address บน Physical Interface นั้นๆ ได้

Note: Interface VLAN จะเป็น Layer 3 Interface หรือ RoutePort โดยกำเนิด

เนื่องจากท่านต้องการให้ Layer 3 Switch สามารถทำการ routing ระหว่าง Subnet ได้ 
ดังนั้นท่านยังคงต้อง enable ความสามารถของการทำ routing โดยการใส่ command "ip routing" อย่างหนีไม่พ้น

ภาพเพิ่มเติม เพื่อเสริมความเข้าใจอย่างถ่องแท้ - ภาพแสดง Layer 3 Switch Logical View ที่หลายๆ คนยังมองไม่ออก

- Mapping Command Line ให้กลายเป็นภาพ



 
ขอบคุณครับ
 
โก้-ชัยวัฒน์ (KoChaiwat)




 

Create Date : 01 มีนาคม 2561   
Last Update : 8 เมษายน 2562 10:51:43 น.   
Counter : 4909 Pageviews.  


OSI and TCP/IP Layer



ผมอนุญาติให้สถาบันการศึกษาของไทย สามารถนำใช้สอนเด็กๆ ได้ โดยไม่ได้นำไปแสวงหาผลประโยชน์เชิงพานิช หรือแสวงหากำไรนะครับ


เรื่อง OSI and TCP/IP Layer ขอให้ดู VDO ทั้งหมดตาม link นี้ประกอบนะครับ จะทำให้ท่านเข้าใจภาพข้างล่างมากขึ้น

https://www.bloggang.com/viewblog.php?id=likecisco&date=04-06-2016&group=11&gblog=1 


สำหรับคำอธิบายภาพข้างล่าง ในขณะนี้ ผมไม่มีเชียน และไม่มีเวลาทำ clip สอน แต่ขอให้ภาพ ทำหน้าที่แทนคำพูดล้านคำนะครับ

ภาพที่ 1



ภาพที่ 2



ภาพที่ 3



ภาพที่ 4



ภาพที่ 5



ภาพที่ 6

สำหรับ ภาพที่ 6 นี้ ท่านสามารถอ่านข้อมูลประกอบได้ตาม link นี้ครับ

https://www.bloggang.com/mainblog.php?id=likecisco&month=12-07-2015&group=3&gblog=51




สำหรับตอนนี้ผมได้แชร์ VDO ที่อ้ัดไว้ระหว่างสอน CCNA สำหรับเรื่องนี้ โดยท่านสามารถเข้าไปรับชมได้ตาม link นี้ครับ

   - Pre CCNA KoChaiwat Vol. 3:
อธิบายถึง OSI และ TCP/IP Layer (เน้นที่ TCP/IP Layer เป็นหลัก) และความสัมพันธ์กันของแต่ละ Layer โดยแสดงให้เห็นในลักษณะของ Packet Flow


ขอบคุณครับ
โก้-ชัยวัฒน์




 

Create Date : 21 กุมภาพันธ์ 2561   
Last Update : 17 สิงหาคม 2561 8:49:34 น.   
Counter : 5639 Pageviews.  


1  2  3  4  5  6  7  8  9  10  11  12  

BlogGang Popular Award#15


 
kochaiwat
 
Location :
กรุงเทพฯ Thailand

[Profile ทั้งหมด]

ให้ทิปเจ้าของ Blog [?]
ฝากข้อความหลังไมค์
Rss Feed
Smember
ผู้ติดตามบล็อก : 693 คน [?]




เริ่มงานครั้งแรกที่บริษัท UIH (United Information Highway) ซึ่งเป็นบริษัทผู้ให้บริการทางด้านการสื่อสารข้อมูล อาทิเช่น Lease Line, Frame Relay และ MPLS และได้ย้ายไปร่วมงานกับบริษัท dtac โดยได้ทำงานเกี่ยวกับ IP Network (Switch/Router/Firewall/F5-Loadbalancer) รวมถึง MPLS Network และ IPRAN (IP Radio Access Network) ซึ่งเป็น IP Network ที่รองรับ Access ของ Mobile System นอกจากนั้นยังสนใจศึกษาเรื่อง IPv6 Address ที่จะมาใช้แทน IPv4 ที่เราใช้งานอยู่ในปัจจุบัน
แต่ด้วยความชอบในการแบ่งปันความรู้ จึงได้มีโอกาสสอน CCNA อยู่ที่สถาบันแห่งหนึ่งในอาคารฟอร์จูนทาวน์ในวันเสาร์-อาทิตย์ ตั้งแต่ปี พ.ศ. 2549 จนถึง พ.ศ. 2553 รวมเป็นเวลา 4 ปี, หลังจากนั้นในระหว่างที่ทำงานที่ dtac ก็ได้สอนเสาร์-อาทิตย์เรื่อยมา

เคยเป็น Trainer หรือ Instructor อย่างเต็มตัว สอนวิชาต่างๆ ของ Cisco อย่างเป็นทางการ (Authorize Training) ที่บริษัท Training Partner Thailand จนถึง มีนาคม 2014 และได้ตัดสินใจออกมาสอนเอง เพราะด้วยความรักในอาชีพการสอน และต้องการที่จะแบ่งปันความรู้ให้กับบุคคลในระดับกลางและล่างเพื่อส่งเสริมให้ได้มีโอกาสได้เรียน และได้มีโอกาสสมัครงาน แต่ด้วยใจรักในบริษัท Cisco ดังนั้น เมื่อมีโอกาสเข้ามา จึงได้ตัดสินใจหยุดการสอน และได้เข้าไปเป็นพนักงาน หรือทำงานที่บริษัท Cisco Thailand ตั้งแต่วันที่ 15 กุมภาพันธ์ 2559 (2016) จนถึงปัจจุบัน

ลูกค้าที่เคยมารับการอบรม เช่น
- Lao Telecom Company Ltd
- CAT Telecom
- TOT
- True
- dtac
- CDG Group
- SITA air transport communications and information technology (www.sita.aero/)
- Infonet Thailand
- MultiLink Co., Ltd
- โรงพยาบาลไทยนครินทร์
- และเคยไปเป็นวิทยากรพิเศษที่ มหาวิทยลัยกรุงเทพสุวรรณภูมิ

ปัจจุบัน โก้-ชัยวัฒน์ ได้ผ่านการสอบ:
- Cisco Certified Internetwork Expert (CCIE) No. 51353 และ
- Cisco Certified Systems Instructor (CCSI) ซึ่งเป็น Certificate ที่ออกให้โดย Cisco สำหรับผู้ที่จะเป็นผู้สอน Cisco Certificate อย่างเป็นทางการ และได้รับ CCSI ID: 34784

วิชาที่สามารถได้สอนได้สำหรับ Cisco Certificate ในขณะนี้คือ
- CCNA Routing & Switching
- CCNA Security (IINS)
- CCNP Route & Switch: ROUTE
- CCNP Route & Switch: SWITCH
- CCNP Route & Switch: TSHOOT
- MPLS (IOS)
- MPLS Traffic Engineering (IOS)
- CCNP Service Provider: SPROUTE (OSPF, IS-IS, BGP, Prefix-List, Route-Map and RPL (Routing Policy Language))
- CCNP Service Provider: SPADVROUTE (Advance BGP, Multicast, and IPv6)
- CCNP Service Provider: SPCORE (MPLS, MPLS-TE, QoS)
- CCNP Service Provider: SPEDGE (MPLS-L3VPN, MPLS-L2VPN (AToM and VPLS)
- IPv6

Certification ที่มีอยู่ในปัจจุบัน CCIE# 51353, CCSI# 34784, CCNA Routing & Switching, CCNA Security (IINS), CCNA Design, CCNP Routing & Switching, CCIP, CCNP Service Provider ซึ่งเป็น Certification ของ Cisco product รวมถึง Certification ของสถาบัน EC-Council (www.eccouncil.org) นั่นคือ Certified Ethical Hacker (CEH)

"เป้าหมายมีไว้ให้ไล่ล่า บ้างเหนื่อยล้าบ้างหยุดพัก
ชีวิตแม้ยากนัก แต่เรารักเราไม่ถอย
ชีวิตแม้ต้องคอย จะไม่ปล่อยไปวันๆ
ชิวิตไม่วายพลัน แม้นสักวันต้องได้ชัย"

"แม้ระยะทางจะไกลแค่ไหน แม้ต้องใช้เวลามากเพียงใด
ขอเพียงแค่มีความตั้งใจ เราต้องได้ไปให้ถึงมัน"

ผมจะไม่ยอมทิ้งฝัน แต่จะไล่ล่ามันให้ถึงที่สุด สักวันฝันอาจจะเป็นจริง ถึงจะไปไม่ถึง แต่ผมก็ภูมิใจที่ได้ทำ
==============================
ความรู้ = เมล็ดพืช
ความพยายามในการเรียนรู้ = ปุ๋ย, น้ำ และความใส่ใจที่จะปลูก
สรุปคือ
ยิ่งพยายามเรียนรู้ ยิ่งพยายามศึกษาในเรื่องใดๆ ผลที่ได้คือ จะได้ความรู้ในเรื่องนั้นๆ อย่างลึกซึ้ง เปรียบเสมือนปลูกต้นไม้ด้วยความใส่ใจ ให้น้ำ ให้ปุ๋ย ผลที่ได้ก็คือ ต้นไม้ที่เติบโตอย่างแข็งแรง และผลิดอกและผลที่งดงามให้เราได้ชื่นชม
ความพยายามอยู่ที่ไหน ความสำเร็จจะอยู่ที่นั่น หรือที่ไหนก็ช่าง แต่เชื่อเถอะ เราจะได้ผลลัพธ์ที่ดีจากความพยายามนั้นๆ ไม่มากก็น้อย
อยากได้อะไรให้พยายาม แล้วความสำเร็จมันจะเข้ามาหาเอง
ผมเชื่อ และมั่นใจอย่างนั้น
===============================
ตอนนี้ผมได้ไปถึงฝัน (CCIE) แล้ว และสิ่งที่ไม่คาดฝัน คือได้ทำงานที่บริษัท Cisco ซึ่งถือได้ว่าไกลเกินฝัน

กว่าผมจะมาถึงจุดนี้ได้ เกิดจากความตั้งใจ มุ่งมั่น และพยายามอย่างไม่ย่อท้อ ศึกษาหาความรู้ และฝึกฝนตนเองอยู่เสมอ จนกระทั่งประสบความสำเร็จ และผมก็ได้พิสูจน์แล้วว่า ความพยายามอยู่ที่ไหน ความสำเร็จอยู่ที่นั่น ขอเพียงแค่อย่าท้อ อย่าถอย และอย่าหยุด

ผมขอเป็นกำลังใจให้กับทุกคน และขอให้ประสบความสำเร็จดังที่มุ่งหวัง ไม่ว่าท่านจะหวังสิ่งใดก็ตามครับ

ท้ายที่สุด ผมขอฝากข้อคิดในเรื่อง Certificate ไว้สักนิดนะครับ:
*** "CCIE และ Certificate อื่นๆ มีไว้เพื่อทำมาหากิน และมีไว้เพื่อข่มตนไม่ให้เกรียน เพราะความเกรียนจะนำมาซึ่งการเป็นเป้าให้คนที่เค้าหมั่นไส้ยิงเอานะครับ" ***

Facebook: Chaiwat Amornhirunwong
New Comments
[Add kochaiwat's blog to your web]

MY VIP Friends


 
 
pantip.com pantipmarket.com pantown.com