˹
 
͸Ժ "network" command router configuration mode

ҵͧ configure routing protocol ѡ protocol ֧ Ҩеͧ command "network" ء ǡԴӶ Ẻ˹ҧ

1. Command"network" Dynamic Routing Protocol IGP RIPv1, RIPv2, OSPF EIGRP ա÷ӧҹ 2 ͧҧ


a. IP address Interface match Ѻ command network Interface
- OSPF Hello 㹡ó configurecommand network Command router ospf
- EIGRP Hello 㹡ó configurecommand network Command router eigrp
- RIP routing update 㹡óշ configurecommand network Command router rip


b. IP address Interface match Ѻ command network Connected Subnet Interface ֧ж١С͡


2. Commandnetwork Dynamic Routing Protocol EGP routingprotocol §㹢й BGP зӧҹ͹Ѻ IGP

router bgp xxx

network 10.1.1.0 mask 255.255.255.0

command network BGP ¶֧ network ҵͧèлС͡仺 BGP routing update͹䢵 network subnet mask лСȹ еͧըԧ routingtable ШͧẺ exact match Ѻ information routing table
觶ҡ
network ҨлСȴ command network ըԧ match routing table command network ռ (С network ͡)


ҡҧ command ͧ router bgp "еͧ network 10.1.1.0/24 ԧ routing table ֧з BGP ӡûС network 10.1.1.0/24 ͡仴 BGP routing update"

========================================================

Ѻ Ǣ command "network" Dynamic Routing Protocol IGP (RIP, OSPF, EIGRP) ѹա駤Ѻ

» network command network statement ˹ҷͧ˹ҷ ѧѺ
˹ҷ 1 enable routing protocol interface: 蹤 IP address interface ͧ router match Ѻ network statement interface 鹨ж١ enable routing protocol network command
!
router eigrp 100
network 172.16.1.0 0.0.0.255
!

router ǹͧ interface
- Fa0/0: IP address 192.168.1.1/24
- Fa0/1: IP address 172.16.1.1/24

ҡҧ:
- IP address interface Fa0/0 match Ѻ network command ѧ router eigrp hello ͡仺 interface Fa0/0
- IP address interface Fa0/1 match Ѻ network commandѧ router зӡ eigrp hello ͡仺 interface ҡ interface Ѻ eigrp router öӡ form neighbor ( AS number ͧ͹ѹ)

˹ҷ 2 С subnet interface: 蹤 IP address interface ͧ router match Ѻ network statement subnet ͧ interface ж١Сȼҹ routing update ͧ routing protocol ( network command ) ѧ router network
!
router eigrp 100
network 172.16.1.0 0.0.0.255
!

router ǹͧ interface
- Fa0/0: IP address 192.168.1.1/24
- Fa0/1: IP address 172.16.1.1/24

ҡҧ:
- IP address interface Fa0/0 match Ѻ network command ѧ router С subnet 192.168.1.0/24 ͡ѧ eigrp neighbor觼 eigrp router ء network ͧ subnet routing table
- IP address interface Fa0/1 match Ѻ network commandѧ router зӡС subnet 172.16.1.0/24 ͡ѧeigrp neighbor觼 eigrp router ء network ͧ subnet routing table


ҡ¹ҵ͡âͧ Cisco ǹ˭ ҷ͡âͧ Cisco ʴ͡ҨѡɳТͧ subnet ͧ interface

router ǹͧ interface
- Fa0/0: IP address192.168.1.1/24
- Fa0/1: IP address172.16.1.1/24

ҡѡѡɳ

óբͧ EIGRP AS 100
!
router eigrp 100
network 192.168.1.0 0.0.0.255
network 172.16.1.0 0.0.0.255
!
--------------------------------------------------------
óբͧ OSPF Process 100 link Area 0
!
router ospf 100
network 192.168.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
!
===================================

㹤繨ԧ "network" command 鹤 match 觹¤ ͧ range ҧ Ẻ subnet ѧҧҹҡ ö IP address ͧ Interface ǵ wildcard mask 0.0.0.0

router ǹͧ interface
- Fa0/0: IP address192.168.1.1/24
- Fa0/1: IP address172.16.1.1/24

óբͧ EIGRP AS 100
!
router eigrp 100
network 192.168.1.1 0.0.0.0
network 172.16.1.1 0.0.0.0
!
--------------------------------------------------------
óբͧ OSPF Process 100 link Area 0
!
router ospf 100
network 192.168.1.1 0.0.0.0 area 0
network 172.16.1.1 0.0.0.0 area 0
!
===================================
͹ IP address interface ºѺ network command šѧ match 蹡ѹ routing protocol ѧӧҹԠ
ʹ ͪͺẺ˹ФѺ ͧ configure ѹٹФѺ Ѻҹѧͧ


˹ ٴ֧ network command ѹ network command command "router eigrp" ѹѧѺ

㹺ҧҵͧ÷ network command Ẻ range ͧ IP address command "router eigrp" ѧ network command "router eigrp" öͧẺѧ

Ẻ 1: Ẻ subnet (¨ҡ class ŧ) еͧ wildcard mask Ҫ
- 172.16.1.1 255.255.255.0 (/24) 172.x.y.z Class B 蹤 172.16.1.1 major network (network 仵 class) 172.16.0.0/16ѧ ҹҵͧ wildcard mask network command ҧա§
- 192.168.1.128 255.255.255.128 (/25)192.x.y.z Class C 蹤 192.168.1.128/25 major network (network 仵 class) 192.168.1.0/24 ѧ ҹҵͧ wildcard mask network command ҧա§


!
router eigrp 100
network 172.16.1.0 0.0.0.255
network 192.168.1.128 0.0.0.127
!
------------------------------------
Ẻ 2: Ẻ major-network network command class
-172.16.0.0 255.255.0.0 (/16) 172.x.y.z class B subnet mask /16 class ѧ蹡ѹ ѧ network command 繵ͧ wildcard mask 蹤
-192.168.1.0 255.255.255.0 (/24) 192.x.y.z class C subnet mask /24 class 蹡ѹ ѧ network command 繵ͧ wildcard mask 蹤


!
router eigrp 100
network 172.16.0.0
network 192.168.1.0
!
Ш Interface ͧ router ҡ IP address 鹵鹴
- 172.16.x.y 192.168.1.z
ж match


ǹͧ "auto-summary" eigrp ͧ "no auto-summary" ҷҹʹͧҹ blog ¹ link ҧҧ¤Ѻ

//www.bloggang.com/viewblog.php?id=likecisco&date=24-11-2011&group=3&gblog=10


//www.bloggang.com/mainblog.php?id=likecisco&month=13-08-2014&group=3&gblog=18




Create Date : 27 չҤ 2557
Last Update : 25 Ҥ 2558 15:58:32 . 0 comments
Counter : 6466 Pageviews.  
 
Name
Opinion
* code html 觢ͤ੾Ҫԡ

kochaiwat
 
Location :
ا෾ Thailand

[Profile ]

ԻҢͧ Blog [?]
ҡͤѧ
Rss Feed
Smember
Դ͡ : 693 [?]




ҹáѷ UIH (United Information Highway) 繺ѷԡ÷ҧҹâ ҷ Lease Line, Frame Relay MPLS ҹѺѷ dtac ӧҹǡѺ IP Network (Switch/Router/Firewall/F5-Loadbalancer) ֧ MPLS Network IPRAN (IP Radio Access Network) IP Network ͧѺ Access ͧ Mobile System ͡ҡѧʹ֡ͧ IPv6 Address ᷹ IPv4 ҹ㹻Ѩغѹ
¤ͺ㹡觻ѹ ֧͡͹ CCNA ʶҺѹ˹Ҥÿٹǹѹ-ҷԵ .. 2549 ֧ .. 2553 4 , ѧҡҧӧҹ dtac ͹-ҷԵ

Trainer Instructor ҧ ͹Ԫҵҧ ͧ Cisco ҧ繷ҧ (Authorize Training) ѷ Training Partner Thailand ֧ չҤ 2014 ѴԹ͡͹ͧ д¤ѡҪվ͹ еͧ÷觻ѹѺؤдѺҧҧ͡¹ ͡Ѥçҹ ѡ㹺ѷ Cisco ѧ ͡ ֧ѴԹش͹ 繾ѡҹ ͷӧҹѷ Cisco Thailand ѹ 15 Ҿѹ 2559 (2016) ֧Ѩغѹ

١ҷѺͺ
- Lao Telecom Company Ltd
- CAT Telecom
- TOT
- True
- dtac
- CDG Group
- SITA air transport communications and information technology (www.sita.aero/)
- Infonet Thailand
- MultiLink Co., Ltd
- çҺ¹Թ
- Էҡþɷ Է¡ا෾ó

Ѩغѹ -Ѳ ҹͺ:
- Cisco Certified Internetwork Expert (CCIE) No. 51353
- Cisco Certified Systems Instructor (CCSI) Certificate ͡ Cisco Ѻ繼͹ Cisco Certificate ҧ繷ҧ Ѻ CCSI ID: 34784

Ԫҷö͹Ѻ Cisco Certificate 㹢й
- CCNA Routing & Switching
- CCNA Security (IINS)
- CCNP Route & Switch: ROUTE
- CCNP Route & Switch: SWITCH
- CCNP Route & Switch: TSHOOT
- MPLS (IOS)
- MPLS Traffic Engineering (IOS)
- CCNP Service Provider: SPROUTE (OSPF, IS-IS, BGP, Prefix-List, Route-Map and RPL (Routing Policy Language))
- CCNP Service Provider: SPADVROUTE (Advance BGP, Multicast, and IPv6)
- CCNP Service Provider: SPCORE (MPLS, MPLS-TE, QoS)
- CCNP Service Provider: SPEDGE (MPLS-L3VPN, MPLS-L2VPN (AToM and VPLS)
- IPv6

Certification 㹻Ѩغѹ CCIE# 51353, CCSI# 34784, CCNA Routing & Switching, CCNA Security (IINS), CCNA Design, CCNP Routing & Switching, CCIP, CCNP Service Provider Certification ͧ Cisco product ֧ Certification ͧʶҺѹ EC-Council (www.eccouncil.org) 蹤 Certified Ethical Hacker (CEH)

" ҧ˹Һҧشѡ
Եҡѡ ѡ
Եͧ ѹ
Ե¾ѹ ѡѹͧ"

"зҧ˹ ͧҡ§
§դ ҵ֧ͧѹ"

駽ѹ ѹ֧ش ѡѹѹҨ繨ԧ ֧֧ 㨷
==============================
= 紾ת
㹡¹ = , Ф㨷л١
ػ
觾¹ 觾֡ͧ ŷ ͧ ҧ֡ º͹١¤ ŷ Ժҧç мԴ͡мŷ觴蹪
˹ 稨 ͷ˹ҧ ҨѾըҡ ҡ
ҡ Ǥѹͧ
ҧ
===============================
͹件֧ѹ (CCIE) 觷Ҵѹ ӧҹѷ Cisco 觶Թѹ

ҼҶ֧ش Դҡ оҧͷ ֡Ҥ н֡ͧ з觻ʺ м٨ ˹ §ҷ Ҷ ش

繡ѧѺء Тʺ稴ѧѧ ҷҹѧ㴡Ѻ

·ش ͽҡͤԴͧ Certificate ѡԴФѺ:
*** "CCIE Certificate ͷҡԹ ͢¹ Ф¹йҫ觡餹ԧҹФѺ" ***

Facebook: Ѳ ѭǧ
New Comments
[Add kochaiwat's blog to your web]

MY VIP Friends


 
 
pantip.com pantipmarket.com pantown.com