กินไม่ได้....แต่เลว 555
Group Blog
 
All Blogs
 

[PT] Config Router Cisco : Vlan Routing ด้วย Switch L3

  ใน การ Routing นั้น  นอกเหนือจาก Router แล้ว

Switch  ยังมีความสามารถในการทำ Routing เบื้องต้นได้ด้วยครับ

โดยความสามารถนี้จัดอยู่ในระดับ  Layer Switch ขึ้นไป

ซึ่ง  อาศัย Interface ของ Vlan  ที่ถูกสร้างขึ้นมา  ทำการ  Routing กันครับ

โดยตัวอย่างต่อไปนี้เป็น การทำ Routing ด้วย Switch Layer3

อาจมีการเพิ่ม Router  และ RIP Protocol นิดหน่อยเพื่อทำให้เห็นภาพ

พร้อมแล้วก็ไปเริ่มกันเลย



โดย LAB  ต่อไปนี้ผมได้แบ่ง Vlan ออกเป็น

Vlan 1  : 111.111.111.0/24
Vlan 10 :  192.168.10.0/24
Vlan 20 : 192.168.20.0/24
server : 10.10.10.0/24

โดย Vlan 1,10,20  จะถูก Routing ด้วย  Core Switch  

และ  Server  จะถูก Routing ด้วย RIP Protocol 

เริ่มกันเลยดีกว่าครับ

เริ่มจากการส้ราง Interface Vlan และ IP Address ที่ Core Switch 

interface Vlan1
 ip address 111.111.111.10 255.255.255.0
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0

 จากนั้น  ทำการตั้งค่า  Port Switch  ที่เชื่อต่อกับ PC  ให้เป็น Access แยก Vlan

interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 20
 switchport mode access


เนื่องจาก Vlan 1 เป็น Default อยู่แล้ว  จึงไม่จำเป็นต้องตั้งก็ได้ครับ

จากนั้น  

ให้ใช้คำสั่ง   ip routing  เพื่อเป็นการเปิดการ Routing  ให้ทำงาน


คราวนี้มาดู ฝั่ง Router กันบ้าง
เราจะทำการ Config  Ip Address  ให้กับ Interface  ของ Router  

ที่ต่อเข้ากับ Switch และ Server ได้ด้วยการใช้คำสั่ง


interface GigabitEthernet0/0
 ip address 111.111.111.1 255.255.255.0
no shutdown

interface GigabitEthernet0/1
 ip address 10.10.10.1 255.255.255.0
no shutdown

(คำสั่ง no shutdown  เป็นคำสั่งสำหรับเปิดการทำงานอขง Port นั้นๆครับ  สำคัญมาก  ถ้าไม่ใส่  จะไม่ทำงาน)

จากนั้นเราก็ทำการ Routing Ip address ภายในของ  Router  ให้ติดต่อกับได้

ในที่นี่ผมเลือกใช้ RIP Routing Protocol เนื่องจากง่ายต่อการ Config  ที่สุดครับ
 คำสั่งคือ

router rip
 network 10.0.0.0
 network 111.0.0.0

เท่านี้ IP ภายในระหว่าง 2 วงของ Router ก็จะสามารถติดต่อกันได้ครับ

แต่  Router  จะยังไม่สามารถติดต่อ  Vlan 10,20  ได้  เพราะเราไม่ได้เซต Vlan  ให้ Router

เราแก้ไขได้ครับ  เพียงทำได้ง่ายๆคือ  ip route โลด

ด้วยคำสั่ง

ip route 0.0.0.0 0.0.0.0 111.111.111.10 

แต่การใส่ ip router  ให้ติดต่อกันในกรณีนี้จะต้องทำทั้งสองฝั่งครับ  ทั้ง Switch และ Router 

จึงจะสามารถ  ติดต่อหากันได้

กลับไปที่ Core Switch ครับ  ทำการใส่

ip route 0.0.0.0 0.0.0.0 111.111.111.1 

เพียงเท่านี้  ทุกอย่างก็เรียบร้อยครับ

ถ้าหากใครยังงง  หรือมองไม่เห็นภาพ  สามารถโหลด LAB Package Tracker ได้ลองศึกษาดูได้เลยนะครับ








 

Create Date : 17 กรกฎาคม 2557    
Last Update : 17 กรกฎาคม 2557 16:56:03 น.
Counter : 1929 Pageviews.  

[PT] Config Router Cisco : การเข้ารหัส รหัสผ่านสำหรับเข้าจัดการ Config Router Cisco

  ว่าด้วยเรื่องการ Config Router Cisco  ครับ  สำหรับตัวอย่างนี้ผมทำไว้ทบทวน  และ เผื่อแผ่แก่เพื่อนๆ พี่ๆ น้องๆ ที่สนใจด้านการ Config Network นะครับ  
อาจมีผิดบ้างถูกบ้างก็อย่างว่ากันนะ



เริ่มต้นด้วยเรื่องง่ายๆ  อย่างการ Config  Password ในการเข้าสู้ IOS ของ Router Cisco กันนะครับ

อย่างแรกเลย  การเข้าสู่การ   Config  Router Cisco  สามารถเข้ามาได้หลักเลย  2 ทาง  (มีมากกว่านั้น  แต่ไม่เป็นที่นิยม)

1. Line Console
2. Telnet

ดังนั้น  หลักๆเลยในการสร้าง Security เพิ่มความปลอดภัยให้ Router  ไม่ให้ใครก็ได้สามารถเข้ามาแก้ไข  หรือดูค่าที่เราตั้งไว้ได้ก็คือการส้ราง Password

โดย password  สพหรับเข้าสู้ Config Terminal  นั้นสามารถตั้งได้  2  แบบคือ

1. enable password 
2. enable secret 

โดยทั้ง 2 คำสั่งนี้แตกต่างกันตรงที่

enable password   เวลาที่สั่ง Show Running-config  จะแสดงรหัสผ่านแบบเต็มไม่มีการเข้ารหัส

แต่ enable secret จะเข้าแสดงเป็นรหัสผ่านแบบเข้ารหัสไว้แล้วนั้นเอง

ในตัวอย่างนี้จะใช้แบบ  enable secret 

รูปแบบ
ยกตัวอย่าง  
enable secret 123##456 

เมื่อทำการ Show running-config  จะแสดงเป็น  

enable secret 5 $1$mERr$SRf/7aXozYekLATtCfmti/


เป็นต้น

ส่วนต่อไป  การตั้ง Password  เข้า Config  ด้วย  Line Console

line con 0
 password 666##777  <<<<รหัสผ่านคือ 666##777
 login

ส่วนคำสั่งการตั้งค่า  ผ่าน Telnet คือ  

line vty 0 4
 password 555##666 <<< รหัสผ่านคือ   666##777
 login

และคำสั่งสุดท้ายที่น่าสนใจที่สุดก็คือ  service password-encryption

โดยคำสั่งนี้  จะทำให้ทุกรหัสใน running-config  แสดงเป็นรหัสแบบเข้ารหัสเมื่อถูกสั่ง Show running-config  

เช่น  line con 0
 password 7 08771A184A5A524045
 login
!
line aux 0
!
line vty 0 4
 password 7 0874191B4A5A534144
 login

นั่นคือรหัสผ่านที่ผมตั้งไว้ก่อนหน้านั้นนั่นเอง

สำหรับใครที่สนใจ  ผมได้ทำการ Upload File LAB ของ Package Tracer 6  ไว้แล้วนะครับ

โดยโหลดได้จาก




 

Create Date : 17 กรกฎาคม 2557    
Last Update : 17 กรกฎาคม 2557 16:10:18 น.
Counter : 532 Pageviews.  

ว่าด้วยเรื่อง Bridge Mode และความแตกต่างของ Modem/Router

อย่างแรกเลยก็ต้องแยกความต่างของ

Modem ,Router ,Modem-Router (AdslRouter)

ออกจากกันนะครับ  เห็นยังมีหลายคนสับสน  

โดยส่วนมาก ADSL ในเมืองไทยจะเชื่อมต่อผ่านสายโทรศัพท์ เป็น Port แบบ RJ11  นะครับ ส่งสัญญาณแบบ Analog 
โดย แต่สัญญาณ Internet  ที่ใช้กันผ่านสาย LAN  (RJ45) จะส่งสัญญาณแบบ Digital


สัญญาณ อนาล็อก (Analog Signals) =  คือสัญญาณแบบคลื่น หรือเรียกว่าสัญญาณเสียงก็ได้ครับ

สัญญาณ ดิจิตอล (Digital Signals)  = คือสัญญาณไฟฟ้า โดยจะส่งสัญญาณ แบบ เปิด, ปิด  หรือ 1,0 นั่นแหละครับ



Modem = ใช้ทำการเชื่อมต่อ Internet ครับ  โดยสามารถเชื่อมต่อได้หลากหลาย Protocal  แต่เป็นที่นิยมใช้ในบ้านเราคือ  PPOE-LLC  ครับ
โดยการเชื่อต่อจะมี Port แบบ RJ11  หรือ  หัวโทรศัพท์นั่นแหละครับ




Router = มีความสามารถหลายหลายครับ  แต่จุดประสงค์หลัก คือ  เป็นอุปกรณ์ในการชี้ทาง (routing) และ NAT ( Network Translate Address )  
การชี้ทาง  พูดง่ายๆคือการทำหน้าที่ว่า IP  ไหน  จะไปทางไหน นั่นแหละครับ  
ส่วน NAT  ทำหน้าที่แปลง IP จำลอง ให้ออกไปเป็น IP จริง  ต้องทราบว่า  จะออก Internet  ได้  จะต้องมี Public IP หรือ IP จริง  โดยเน็ต ADSL  ก็จะได้ IP จริง  
แต่เวลา Connect IP  จะเปลี่ยนไปเรื่อยๆ เรียกว่า (Dynamic IP) ครับ  โดยการ NAT  จะทำหน้าที่แปลง IP เสมือนในวงแลนของคุณ  
ยกตัวอย่างเช่น  192.168.1.xx  ให้กลายเป็น 110.211.7.33  แล้วถึงจะออกอินเตอร์เน็ตได้ครับ  ปัจจุบัน Router  มี ความสามารถต่างๆเพิ่มขึ้นมามากมายครับ  



Modem-Router  =  คือการนำ Modem และ Router  มารวมความสามารถเป็นอุปกรณ์ตัวเดียวกันครับ  โดย  จะมีทั้ง Port RJ11 , RJ45  บางรุ่นมี Wireless  ติดมาด้วยอีกต่างหาก 

ข้อดีคือ  ลดจำนวนอุปกรณ์ให้น้อยลงครับ ง่ายต่อการ Config, ลดจำนวน Adapter และปลั๊กไฟครับ  
ข้อเสียคือ หาก Function ใดทำงานผิดพลาด  จะมีผลกระทบต่อ Function อื่นๆด้วย (แต่ไม่เสมอไปนะครับ)



Bridge Mode  = ตามชื่อเลยครับ  คือ mode สะพาน ทำหน้าที่แค่แปลงสัญญาณจาก Analog  จาก Port RJ11 (โทรศัพท์)  ให้เป็น Digital  
ส่งผ่าน Port LAN  ไปให้ Router  เป็นตัว Connect Internet เท่านั้นครับ



สำหรับการเลือกใช้  การเชื่อต่อแบบใดนั้น  ขึ้นอยู่กับว่า  คุณมีอุปกรณ์แบบไหน  และต้องการใช้งานแบบไหนครับ
การเชื่อต่อแต่ละแบบมีข้อดีข้อเสียต่างกันไปครับ  เลือกให้ตรงกับความต้องการและทรัพยากรณ์ที่มี แล้วคุณจะได้ระบบที่ถูกใจที่สุดครับ




 

Create Date : 25 กุมภาพันธ์ 2557    
Last Update : 25 กุมภาพันธ์ 2557 21:40:17 น.
Counter : 1349 Pageviews.  

WiFi แรงขึ้น 2 เท่า ด้วยที่ตีไข่ จริงหรือ?

เห็นคลิปนี้อยู่ในข่าวของเว็บ Sanook.com เลยเอามาบอกว่าอย่าไปคิดว่ามันจะเพิ่มความเรฝ้วเน็ตจาก ISP นะครับ




คือจริงๆแล้ว มันไปเพิ่มเพียงความแรงของช่องสัญญาณ WIFI 

โดยเฉพาะหากคุณอยู่ในที่แออัดด้านสัญญาณ เช่น คอนโด, ห้างสรรพสินค้า 

เจ้าที่ตีไข่มันจะช่วยเพิ่มความแรงของสัญญาณ WIFI คุณให้แรงกว่าชาวบ้าน (แล้วชาวบ้านเขาจะอืดสุดๆเลย) 

ทำให้รับส่งสัญญาณได้แรงขึ้น ใช้ Internet ได้เต็ม speed แต่ไม่ได้ช่วยให้ Internet ของคุณไวขึ้นนะครับ 

เช่น ถ้าคุณซื้อเน็ตจากทรูไว้ speed เดือนละ 10 เมก มันก็จะอยู่ ที่ 10 เมกเสมอ ไม่ได้แรงขึ้นมากกว่านั้นนะครับ




 

Create Date : 25 กุมภาพันธ์ 2557    
Last Update : 25 กุมภาพันธ์ 2557 11:49:45 น.
Counter : 188 Pageviews.  

RS232 ???

RS232  แม่งคืออะไรวะ???

คำถามนี้เกิดขึ้นกับผมตอนเริ่มทำงานเกี่ยวกับ  Network  ครั้งแรก

เพราะต้อง  Config  Switch  H3C  เป็นงานแรกหลังจากบริษัทนี้  พลาดรับผมเข้ามาทำงาน

"มันคือที่ต่อกับ  port  serail  ไง"

คำอธิบายสั้นๆ  จากพี่ที่ทำงาน  ที่ช่วยได้ดีมาก  งง  เข้าไปอีก

ก็พอจะรู้บ้างว่าสมัยก่อนเวลาต่อ  printer  มันก็ต้องต่อผ่าน  port  serail 

แต่เพิ่งจะรู้ว่า  ถ้าต้องคอนฟิกอุปกร  Network  ก็ต้องมีความรู้เกี่ยวกับมัน

เลยต้องไปหาข้อมูลกับ  อากู๋  ก้พบเจอกับเว็บนี้ 

http://www.thaimicrotron.com/CCS-628/Referrence/RS232.htm


เว่ากันซื่อๆคือ  RS232  มันก็คือ  Port  ที่ใช้สำหรับส่งข้อมูลโดยตรงไปยังอุปกรณ์  จำพวกที่มี  ไมโครคอนโทรเล่อร์อยู่นั่นเอง



ซึ่งปัจจุบันก็ยังใช้งานกันแพร่หลายและยังเป็นที่นิยมอยู่มาก
ในการทำงานเชิงวิศวกรรมและ  Network



เพราะแม้ใจปัจจุบันอุปกรณ์ Network  จำพวก Switch,Router,Access Point  ที่ใช้กันในเชิงธุรกิจก็ยังต้องพึ่งเจ้า  RS232  ในการ  Config  อยู่



ในตอนหน้า (ถ้าว่าง)  เราจะมาเว้ากันถึงวิธีใช้  RS232  ในการ  Config Switch  กัน





 

Create Date : 26 มีนาคม 2555    
Last Update : 26 มีนาคม 2555 22:30:52 น.
Counter : 431 Pageviews.  


แมงปอซ่า
Location :
กรุงเทพฯ Thailand

[Profile ทั้งหมด]

ให้ทิปเจ้าของ Blog [?]
ฝากข้อความหลังไมค์
Rss Feed
Smember
ผู้ติดตามบล็อก : 1 คน [?]




ปลายทางชีวิตไม่ไช่จุดหมาย แต่ความฝันตางหากคือจุดหมาย

รอสักหน่อยเถอะนะฝัน....สักวันฉันจะไปให้ถึงนาย
Friends' blogs
[Add แมงปอซ่า's blog to your web]
Links
 

 Pantip.com | PantipMarket.com | Pantown.com | © 2004 BlogGang.com allrights reserved.